注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

淘尽网 官方博客

淘尽网http://www.tao3w.com做最好的比价网站

 
 
 

日志

 
 
关于我

淘尽网 http://www.tao3w.com 做最好的比价网站,做最好的数据抓取专家。

网易考拉推荐

centos编译安装gstm  

2017-08-26 10:20:48|  分类: LINUX |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
1、从https://sourceforge.net/projects/gstm/?source=typ_redirect页面下载,实际文件路径是:https://nchc.dl.sourceforge.net/project/gstm/gSTM/gSTM-1.2/gstm-1.2.tar.gz下载
2、编译./configure; make; make install
3、进行./configure时候遇到如下错误
1)、提示 Package requirements (libgnomeui-2.0) were not met.错误
[root@localhost gstm-1.2]# yum search libgnomeui-dev
[root@localhost gstm-1.2]# yum install libgnomeui-devel.x86_64
2)、重新./configure,make,在make时候遇到如下错误:
1 
/usr/bin/ld: conffile.o: undefined reference to symbol ‘xmlTextWriterEndElement@@LIBXML2_2.6.0′ 
2 
/usr/bin/ld: note: ‘xmlTextWriterEndElement@@LIBXML2_2.6.0′ is defined in DSO /usr/lib/libxml2.so.2 so try adding it to the linker command line 
3 
/usr/lib/libxml2.so.2: could not read symbols: Invalid operation
[root@localhost gstm-1.2]# vim src/Makefile 
找到gstm_LDADD,在末尾加入-lxml2 -lX11,整体命令为: 

1 
gstm_LDADD = -pthread -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt
2 
-lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 
3 
-lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lpng12 -lm -lcairo -lpango-1.0 -lfreetype -lfontconfig 
4 
-lgconf-2 -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lxml2 -lX11  $(INTLLIBS)
 
[root@localhost gstm-1.2]# make & make install
参考http://qq85609655.iteye.com/blog/2055593
  评论这张
 
阅读(1)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017