注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

淘尽网 官方博客

淘尽网http://www.tao3w.com做最好的比价网站

 
 
 

日志

 
 
关于我

淘尽网 http://www.tao3w.com 做最好的比价网站,做最好的数据抓取专家。

网易考拉推荐

yum安装指定版本的软件包的方法  

2016-08-04 15:31:45|  分类: LINUX |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

yum默认都是安装最新版的软件,这样可能会出一些问题,或者我们希望yum安装指定(特定)版本(旧版本)软件包.所以,就顺带分享yum安装指定(特定)版本(旧版本)软件包的方法。

过程如下:
假设这里是我们想安装的是prce ,输入:
#yum         list          prce
输出:
pcre-7.8-6.el6.i686:Perl-compatibleregularexpressionlibrary
pcre-7.8-6.el6.x86_64:Perl-compatibleregularexpressionlibrary
pcre-7.8-6.el6.x86_64:Perl-compatibleregularexpressionlibrary

找到你要安装的版本的完整的名字,这里安装pcre-7.8-6.el6.i686,输入:
#yum  install  pcre-7.8-6.el6.i686 -y
安装完后,就是检查pcre的版本了,输入:
# rpm -qa | grep pcre
就可以看到你安装的版本是不是你要的了。
转自 http://www.dabu.info/yum-install-specific-version-old-package.html

yum 安装多个 或卸载多个软件包

安装多个类似软件时
yum -y install httpd*
安装多个非类似软件时
yum -y install httpd php php-gd mysql

 

卸载一个软件时
yum -y remove httpd
卸载多个相类似的软件
yum -y remove httpd*
卸载多个非类似软件时
yum -y remove httpd php php-gd mysql

  评论这张
 
阅读(167)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017