注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

淘尽网 官方博客

淘尽网http://www.tao3w.com做最好的比价网站

 
 
 

日志

 
 
关于我

淘尽网 http://www.tao3w.com 做最好的比价网站,做最好的数据抓取专家。

网易考拉推荐

ubuntu下配置安装PYQT4  

2012-07-28 08:25:44|  分类: python |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

本人linux菜鸟,以下内容不定期更新

首先安装SIP,是一个将python和c/c++库关联起来的工具,也是pyqt的依赖工具

http://www.riverbankcomputing.com/software/sip/download
下载后用Archive Manager解压,打开终端定位到该目录(cd)
sudo python configure.py

make

sudo make install 

 注意make有没有error,如果有Python.h未找到错误,说明没有安装对应python版本的dev包,解决方法是

sudo apt-get install python2.6-dev

 

当然你的python是什么版本就装什么

此外make install后包文件和解压的文件夹斗可以删除

然后下载pyqt4

http://www.riverbankcomputing.com/software/pyqt/download

解包后和上面同样的操作

 

此外说到开源的pythonIDE,推荐一下Eric,最新版本是5,包括了图形界面编程,挺不错。毕竟VIM对于初学者太难了。

注意如果要用Eric5的话需要安装python3,而ubuntu下python2和3是可以共存的

 

sudo apt-get install python3.1-minimal
sudo apt
-get install python3.1
sudo apt
-get install python3.1-dev

 如果以后需要运行python3的脚本,则要用sudo python3 xxx.py,

 使用python3配置上面各个包

此外尚需Qscintilla

http://www.riverbankcomputing.co.uk/software/qscintilla/download

解包后查看readme文件操作,很简单。 

即可搭建eric5的运行前提

  评论这张
 
阅读(826)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017